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About This Book

This guide explains how to build and execute Windows Embedded CE 6.0 OS images for the
3-Stack board, using the Freescale i.MX31 PDK Windows Embedded CE 6.0 Board Support
Package (BSP).

Audience

This document is intended for software, hardware, and system engineers who are planning to use
the product and for anyone who wants to understand more about the product.

Organization

This document contains the following chapters.

Chapter 1 Describes the contents and organization of the BSP.

Chapter 2 Explains how to install/uninstall the BSP.

Chapter 3 Explains how to configure the OS images.

Chapter 4 Explains how to build the OS images and download the bootloader.
Chapter 5 Describes how to download the bootloader.

Chapter 6 Explains how to download the OS images.

Chapter 7 Describes the Windows Embedded CE 6.0 projects you can create with the BSP.

Conventions

This document uses the following conventions:

Courier Is used to identify commands, explicit command parameters, code
examples, expressions, data types, and directives.

Italic Is used for emphasis, to identify new terms, and for replaceable command
parameters.

References

The following documents were referenced to build this document.

1. i.MX31 Hardware User’s Guide
2. 1.MX Advanced ToolKit Standard Version User’s Guide
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Chapter 1

Introduction
Using this document, you perform the following tasks in sequential order:
. Install the development tools and BSP
. Configure the OS images
o Build the OS images and bootloader
o Download the bootloader
o Download the OS images
J Use the applications

The Freescale i.MX31 3-Stack BSP is a collection of code and support files that can be integrated
into the Microsoft Platform Builder development environment to create Windows Embedded CE
6.0 OS images for the 3-Stack board.

The BSP contains the following elements:
o Boot loader for downloading OS images
OEM Adaptation Layer (OAL) for providing the kernel hardware interface
Device drivers to support on-chip and on-board peripherals
Image configuration and build files

1.1 System-on-Chip Support Package (SoC)

The Freescale SoC directory contains a collection of chipset-level code that you can leverage to
develop platforms based on the i.MX31 SoC. You can use the driver code and definitions in the
SoC directory in a new platform design for the i.MX31 without modification.

To keep the SoC sources platform-agnostic, drivers in the SoC directory utilize hardware
abstraction routines that must be ported to a specific platform or board. The SoC source code is
compiled into a set of static libraries that are ultimately linked with platform-specific libraries to
create drivers for the system.

The following directories contain the SoC source code for the MX31.:

WINCEGOO\PLATFORM\COMMON\SRC\SOC\FREESCALE\COMMON_FSL_V1
WINCEGOO\PLATFORM\COMMONN\SRC\SOC\FREESCALE\MXARM11_FSL_V1
WINCEGOO\PLATFORM\COMMONN\SRC\SOC\FREESCALE\MX31_FSL_V1
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The driver code is reusable:

e The SoC driver code in the MXARM11_FSL_V1 directory is reusable across all Freescale
ARM11-based SoCs.

e The SoC driver code in the MX31_FSL_V1 directory is reusable across all platforms based on
the i.MX31.

1.2 Production Quality OAL (PQOAL)

Where possible, the Freescale BSP leverages the PQOAL architecture and components provided
by Microsoft to reduce the OAL code that needs to be modified and maintained by the OEM. In
addition, PQOAL components customized for the i.MX31 are available in the following
directories:

WINCEGOO\PLATFORM\COMMONN\SRC\ARM\FREESCALE\MXARM11
WINCEGOO\PLATFORM\COMMON\SRC\ARM\FREESCALE\MX31

The PQOAL code is reusable:

e The PQOAL code in the MXARM11 directory is reusable across all Freescale ARM11-based
SoCs.

e The PQOAL code in the MX31 directory is reusable across all platforms based on the i.MX31
device.

1.3 i.MX31 3-Stack Platform Files

All of the driver and OAL content for the i.MX31 3-Stack hardware platform is located in the
following directory:

WINCEGOO\PLATFORM\1MX313DS

The files in this directory implement the hardware abstraction routines invoked by the driver code
in the Freescale SoC directory, as well as certain aspects of the PQOAL that may need to be
modified by the OEM for a specific platform.

1.4 Sample Workspace

Platform Builder uses design solutions to encapsulate the OS components and build options
needed for the Windows Embedded CE 6.0 tools to generate an OS image.

The BSP provides a default solution, which is located in the following directory:
\WINCE600\OSDesigns\iMX313DSMobi lity
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1.5 Support Files

Support files that complement the BSP source tree are located in the following directory:
\WINCE60O\SUPPORT

This directory contains applications and tests for the 1.MX31 3-Stack BSP, and support files
needed to configure development tools and the ATK for the i.MX31 3-Stack board.
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Chapter 2
Installation

The Freescale 3-Stack Board Support Package (BSP) is a collection of binary, code, and support
files that you use to create Kernel images for the 3-Stack board. The BSP is distributed as a single
archive MSI (.msi) file.

This chapter explains how to install the development tools and BSP, remove an existing BSP
installation, and load a sample OS design solution.

NOTE

Before installing this BSP, check to ensure that no other i.MX
BSP is installed in your system. If there is an installation, see
the appropriate PDK User's Guide for instructions on
removing the installation.

2.1 Installing the Development Tools and BSP

This section explains how to install the Microsoft Windows Embedded CE 6.0 development tools
and the Freescale i.MX31 3-Stack BSP. These installations provide a complete development
environment.

To perform the installations, use these steps:

1. Install Microsoft Visual Studio® 2005, and also install the Visual Studio Service Pack 1.
The Service pack may be downloaded from the following location:

http://www.microsoft.com/products/info/product.aspx?view=22&pcid=b171ab31-2771-
4116-8243-17654838fd72&crumb=srch&qu=visual+studio+2005&qpid=f5459860-188a-
46a3-a825-99fc43a9c5¢cl

For installation instructions, see the Release Notes on the Visual Studio and Platform
Builder installation discs.

2. Insert the Windows Embedded CE 6.0 installation disk.
Optionally, you can download Windows Embedded CE 6.0 from the following link:

http://www.microsoft.com/downloads/details.aspx?familyid=7E286847-6E06-4A0C-
8CAC-CA7D4C09CB56&displaylang=en
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The initial screen is displayed (Figure 1-1).

ii& Windows Embedded CE 6.0 Setup X|

@ Welcome to the Windows
Embedded CE 6.0 Setup
Wizard

The Setup Wizard will install Windows Embedded CE 6.0 on
wour compuker, Click Mest to continue or Cancel ko exit the
Setup Wizard,

= Bach

Zancel |

Figure 2-1 Setup Screen
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3. Proceed with the installer instructions to the Setup section (Figure 1-2), and in the CE 6.0
Operating System folder, ensure that the ARM41™ platform is selected.

|,_:F= Winkbows Ermbedded CE 6,0 Setup
Setup
Select Browse to change the drectory where features ane instaled.
= E-Iwrdminhddrdft 6.0 |
B =] CE 6.0 Took ﬁﬂm'alcrmmgi and ARMLG2Y,
53 = | Windows Embedded CE 6.0 Test i ot
) = | Platform Busider
= | Shared Source
=] = CE £.0 Operating System
=2
¥ =| MIFSII
3 =] MIPSILFP This festure requires Z567ME on
M = | MIFSIV your hard dirve,
X =| MIFSIV_FP
b e
» =] w86
Bucuarfe I
Dok Lsage | < Back [ corcel |

Figure 2-2 Selecting ARM41

NOTE
The ARMVA4I version must be installed on the local hard drive
for this BSP. No other versions are required.

4. Click Next.
5. Follow the installation until it is complete.

6. Install the following updates, which are required by SDK:
Windows Embedded CE 6.0 Platform Builder Service Pack 1
http://www.microsoft.com/downloads/details.aspx?familyid=BFODCOE3-8575-4860-A8E3-
290ADF242678&displaylang=en
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Windows Embedded CE 6.0 R2
http://www.microsoft.com/downloads/details.aspx?FamilylD=f41fc7c1-f0f4-4fd6-9366-
b61e0ab59565&displaylang=en

Windows Embedded CE 6.0 Cumulative Product Update Rollup (12/31/2007)
http://msdn.microsoft.com/en-us/embedded/aa731256.aspx

Windows Embedded CE Updates

Beside previous update requirements, this BSP also need and all 2008 Monthly Updates.
Please install all available updates from January 2008 to November 2008.
http://msdn.microsoft.com/en-us/embedded/aa731256.aspx

NOTE

By the time you install this BSP, it is probable that a new
Cumulative Product Update Rollup (2008) will be available on
the Windows Embedded CE Updates site, replacing the
previous Cumulative Product Update Rollup (2007). The new
package includes all previous updates and would be the only
file you need to install for a proper system update.

2.2 Removing i.MX31 PDK BSP

These instructions remove an installation of the BSP from the Windows Embedded CE 6.0 source
code tree and the Platform Builder development environment.

NOTE

Before uninstalling the BSP, save any modified files that you
want to keep to a protected location, because uninstalling the
BSP will remove all files that were populated by the Microsoft
Windows Installer.

To remove the BSP, use these steps:

1. Close Platform Builder.

2. Perform one of the following steps:
— Rerun the original MSI installer and click Remove.

OR
— Using the Add or Remove Programs Control Panel applet, select the Freescale BSP
item, and then click Remove.

3. Manually remove any remaining BSP files and directories (some of these files and
directories will remain after completing the previous step because they contain object files
or other generated files that were not part of the original BSP installation):
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\WINCE600\0SDesigns\iMX313DSMobility
\WINCE600\PLATFORM\COMMON\SRC\ARM\dirs
\WINCE600\PLATFORM\COMMON\SRC\ARM\FREESCALE
\WINCE600\PLATFORM\COMMON\SRC\SOC\FREESCALE
\WINCE600\PLATFORM\iMX313DS
\WINCE600\SUPPORT

Manually remove the residual BSP library files that were created after the BSP was
installed. To find the libraries, use the Windows Explorer search functionality. Search for
*mxarmll*; *mx31*; *pmic*; *mcl3783* in the following library path, and then
remove all the L 1B, PDB, and DEF files found by the search:

\WINCE600\PLATFORM\COMMON\LIB\ARMV4 I

Restore the original version of the following file:
WINCE600\PLATFORM\COMMON\SRC\ARM\dirs

Load Sample OS Design Solution

After installing the BSP, you can use the sample OS solutions provided in the BSP package to
build a Windows Embedded CE 6.0 OS image.

To load the OS image, use these steps:

1.
2.

In Platform Builder, select File > Open > Project/Solution...

Select the i.MX31 BSP sample workspace by loading the following file:
WINCE600\0SDesigns\iMX313DSMobility\iMX313DSMobility.sln

The process of loading this solution also loads the associated i.MX31 BSP catalog.

Select the Catalog Items View tab to see all of the available OS solution catalog items.
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Chapter 3
Configuring OS Images

This chapter describes the configuration options available for the i.MX31 BSP. You will use
Platform Builder to select one of the two default build configurations provided with the BSP
sample solution. These configurations control the type of OS image (debug or release) that will be
generated by the Platform Builder tools.

The build configuration encapsulates all of the platform environment variables and custom build
instructions that will be used during OS image creation.

Use Platform Builder to select a configuration.

NOTE

The sample solution provided in the BSP is correctly
configured to generate a default image targeted for the
1.MX31 3-Stack board. It is not necessary to adjust any of the
image configuration settings prior to building the BSP.

3.1 Selecting the Image Build Type
To select the type of OS image to be generated by Platform Builder, use these steps:

1. Click Build > Configuration Manager.

2. Select Set Active Configuration. The sample workspace provided with the BSP provides
two image build types:

Freescale i.MX31 3DS: ARMV4I_Release —Retail build that includes KITL and kernel
debugger support. This image type provides a smaller image with faster execution at the
expense of limited debug capability.

Freescale i.MX31 3DS: ARMV4I_Debug—Debug build that includes KITL and kernel
debugger support. This image type provides full debug capability at the expense of a larger
image size and slower execution.

For more information about the build types available for Windows Embedded CE 6.0, see the
“Build Configurations” topic in the Windows Embedded CE 6.0 Help.
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3.2 Configuring the BSP Environment Variables

The BSP environment variables control the optional BSP support for OS images. Select the BSP
environment variables using the Project > Properties > Configuration Properties >
Environment configuration dialog and the i.MX31 3-Stack BSP Catalog.

The subsections that follow explain how to configure the BSP environment variables and describe
the supported variables.

3.3 Configuration Properties Environment Variables

Use the Platform Builder solution to set the BSP environment variables for each build
configuration.

To view and configure the variables, use these steps:

1. Open the sample solution for the BSP.
2. From the Project menu, select iMX313DSMobility Properties.

3. Expand Configuration Properties if necessary and select Environment.

Note

After modifying the environment value in the Properties

window, also change the related value in the following

location:
\wince600\platform\iMx313DS\imx313ds.bat

For a Release build type, all environment values are defined in
this bat file.
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The Environment Variables dialog (Figure 3-1) is displayed, showing a list of the environment
variables. Table 3-1 describes the BSP environment variables.

M3 13D5Mobility Property Pages

Configuration: IAcﬁ'-.-'E(FreescaIe i_Mx31 j FlakFarm: II-J..",-'J.

EI Cpmmnn Properties
i Build Tree (WINCEROQOT)

Environment variables:

=]

: ariahle | Value |
=- Cpnﬁgurat’an Properties bsp_no_trust 1
i General bep_nand_k&2g08la 1
Locale imgnand 1
- Build Options build_options FREESCALE MXARMT1T Mx...
_tgtboard . 305
- Cugtom Build Actions Eip—ggﬁazus :II
i Subproject Image Settings =
Mew... | Edit... | Remove |
Ok I Cancel | Apply

2%

Configuration Manager. .. |

Figure 3-1 Environment Variables

Table 3-1 BSP Variables

BSP Variables

Description

Settings

BSP_NOPCIBUS

Used to exclude support for the
PCI bus.

BSP_NOPCIBUS = 1

Excludes PCI bus support from the OS
image.

DO NOT remove from sample workspace.

BSP_NOCSPDDK

Used to exclude i.MX31 CSP
driver development kit (CSPDDK)
support. The CSPDDK is required
for most BSP device drivers.

BSP_NOCSPDDK = 1

Excludes CSPDDK from the OS image. Use
this configuration only when building an OS
design that does not include BSP device
drivers.

DO NOT define for sample workspace.

BSP_NOAUDIO

Used to exclude support for audio
driver.

BSP_NOAUDIO = 1

Excludes audio driver support from the OS
image.

BSP_NODISPLAY

Used to exclude support for
display driver.

BSP_NODISPLAY =1

3-8
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BSP Variables

Description

Settings

Excludes display driver support from the OS
image.

BSP_NOTOUCH

Used to exclude support for touch
driver.

BSP_NOTOUCH =1

Excludes touch driver support from the OS
image.

BSP_NONLED

Used to exclude support for
notification LED driver.

BSP_NONLED =1

Excludes notification NLED driver support
from the OS image.

BSP_NO_TRUST

Excludes trusted environment
support to the image.

BSP_NO_TRUST =1

Excludes trusted environment support from
the OS image.

DO NOT remove from sample workspace.

BSP_WARNLEVEL

Selects the compiler
warning/verbosity level. See the
online help for the /w compiler
option for additional information.

Note that WARNISERROR=1 is
also defined by default in the
PUBLIC\COMMON\sources.cmn,
PLATFORM\COMMON\sources.c
mn, and the
PLATFORM\IMX313DS\sources.c
mn files so that any compiler
warnings will be treated as build
errors.

BSP_WARNLEVEL=4

This means that compiler level 4 warnings
will be displayed and treated as build errors
if WARNISERROR-=1 is also defined.

_TGTBOARD

Allows conditional compilation for
the i.MX31 3-Stack hardware.

_TGTBOARD = 3DS

Configures the build for i.MX31 3-Stack
hardware.

Note: A clean build of all BSP components is
required after modifying this setting.

BUILD_OPTIONS

Specifies an optional set of BSP
directories for the build tools.

BUILD_OPTIONS = FREESCALE
MXARM11 MX31 MXARM11_FSL_V1
MX31_FSL_V1 PMIC

Required for proper build of BSP. DO NOT
modify or remove from sample workspace.

BSP_NAND_K9F2G08R0A

Used by EBOOT and OS build
files

BSP_NAND_K9F2G08RO0A = 1

DO NOT remove from sample workspace.

IMGNAND

Used by EBOOT and OS build
files to determine if images are
targeted for NAND flash.

IMGNAND = 1

Link EBOOT and OS images for NAND
flash. This environment variable is ignored
for OS images if you have selected the
following:

Platform Settings > Build Options > Write
Run-time Image to Flash Memory
(IMGFLASH=1) to link the OS image for
NOR flash.
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BSP Variables

Description

Settings

BSP_HIVE_ATA

Used to build a HIVE image that
uses ATA as storage media

BSP_HIVE_ATA =1

Note: SYSGEN_FSREGHIVE and
SYSGEN_FSROMONLY should be added in
the solution to build a HIVE image, need
clean build to generate image

BSP_HIVE_SDHC

Used to build a HIVE image that
uses SD as storage media

BSP_HIVE_SDHC = 1

Note: SYSGEN_FSREGHIVE and
SYSGEN_FSROMONLY should be added in
the solution to build a HIVE image, , need
clean build to generate image

BSP_HIVE_NAND

Used to build a HIVE image that
uses NAND as storage media

BSP_HIVE_NAND = 1

Note: SYSGEN_FSREGHIVE and
SYSGEN_FSROMONLY should be added in
the solution to build a HIVE image, need
clean build to generate image

BSP_USB_IRAM_PATCH

Used to build a USB image that
use |IARM instead RAM

BSP_USB_IRAM_PATCH =1
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Chapter 4
Building OS Images and Bootloader

This chapter explains how to build Windows Embedded CE 6.0 OS images using the i.MX31
3-Stack BSP.

4.1 Building SoC Libraries

The Freescale SoC libraries that support the i.MX31 are generated during the following build
procedure:

Build > Advanced Build Commands > Sysgen or Build > Advanced Build Commands >
Build Current BSP and Subprojects

Windows Embedded CE 6.0 ships with pre-built SoC libraries for various ARM processors, but
the libraries for i.MX31 must be built from the sources, because they are not included with the
standard Microsoft distribution.

Note

The provided sample OS design solution is preconfigured to
build the required Freescale SoC. That is, the sample i.MX31
OS design solution will automatically build the i.MX31 SoC
sources.

To build the SoC libraries, use these steps:

1. Open the sample solution.
2. Select the build type, as discussed in Section 3.1, Selecting the Image Build Type.
3. If you have not yet performed a Sysgen operation, select a Sysgen build.

If you have already performed a Sysgen operation, and just need to rebuild the Freescale
SoC libraries, click Build Current BSP and Subprojects.

For a release build type, the SoC libraries will be placed in:
WINCEGOO\PLATFORM\COMMON\L IB\ARMV4 I\RETAIL

For a debug build type, the SoC libraries will be placed in:
WINCEG0O\PLATFORM\COMMON\L IB\ARMV4 I\DEBUG
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4.2 Building Run-Time Images

For instructions for the remaining steps of building an OS image, follow the standard procedures
described in the Platform Builder documentation. For information, see the “Building a Run-Time
Image” topic in the Windows Embedded CE 6.0 Help.

4.2.1 Building the BSP for the First Time

To build the BSP for the first time, use these steps:

1. Open the sample solution. and select the desired build type, as discussed in Section 3.1,
Selecting the Image Build Type.

2. Using the Build > Global Build Settings menu, configure the build options as follows:
— Copy Files to Release Directory After Build selected
— Make Run-Time Image After Build selected

3. Click Build > Advanced Build Commands > Sysgen to start the build (Figure 4-1).

Build Solution F7
Rebuild Solution Ctrl+Alt+F7
Clean Solution

Build iMX 313D5Mobility

F.ebuild iMx31305Mobility

Clean iM% 313D5Mobility

Advanced Build Commands 3 m Sysgen

Clean Sysgen

Build and Sysgen

Rebuild and Clean Sysgen
Copy Files to Release Directory Build Current BSP and Subprojects

Make Run-Time Image Rebuild Current BSP and Subprojects

Open Release Directory in Build Window

Global Build Settings 3
Targeted Build Settings 3
Batch Build...

Configuration Manager. ..

Figure 4-1 Building the BSP for the First Time
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For a release build type, the resulting OS image files are placed in the following directory:
WINCE600\OSDesigns\iMX313DSMobi lity\RelDir\Freescale i_MX31_3DS_ARMV41_Release

For a debug build type, the resulting OS image files are placed in the following directory:

WINCE600\OSDesigns\iMX313DSMobi lity\RelDir\Freescale i_MX31_3DS_ARMV41l_Debug

4.2.2 Obtaining a Clean Build for the BSP

By default, Platform Builder performs incremental builds of the BSP components, even during the
Sysgen build procedure. However, as some time you may want to force a clean build for the BSP.

To obtain a clean build of all the BSP components, use these steps:

1. Using the Build OS menu, configure the build options as follows.
— Copy Files to Release Directory After Build selected
— Make Run-Time Image After Build unselected
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Click Build > Advanced Build Commands > Rebuild Current BSP and Subprojects
to perform a clean build of the BSP platform directory (including the SoC libraries) and
complete the creation of a new OS image. (Figure 4-2).

Build | Debug Target Tools Window Comr
| Build Solution F7

Rebuild Solution Ctrl+alt+7

Clean Solution

Project Only 3
Advanced Build Commands 3 Sysgen
f Build All Subprojects Clean Sysgen
Rebuild All Subprojects Build and Sysaen
Rebuild and Clean Sysgen
| Copy Files to Release Directary Build Current BSP and Subprojects
Make Run-Time Image Rebuild Current BSP and Subprojects

BN OpenRelease Directory in Build Window

Global Build Settings 3
Targeted Build Settings 3
Batch Build...

Configuration Manager...

% Ccompile Chrl4F7

Figure 4-2 Clean Build for the BSP
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4.2.3 Performing an Incremental BSP Build

The Sysgen build phase copies the pre-built OS component binaries to the release directory for
the current build configuration. It is not necessary to perform a Sysgen again unless components
are being added or removed from your OS design. Instead, you can perform an incremental build
of the BSP components to quickly build an updated OS image.

To build an updated OS Image, use these steps:

1. Open a solution.
2. Select the desired build type, as discussed in Section 3.1, Selecting the Image Build Type.

3. Using the Build > Global Build Settings menu, configure the build options as follows:
— Copy Files to Release Directory After Build selected
— Make Run-Time Image After Build selected
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4. Click Build > Advanced Build Commands > Build Current BSP and Subprojects to
perform an incremental build of the BSP platform directory (including the SoC libraries)
and complete the creation of an OS image (Figure 4-3).

Build | Debug Target Tools Window  Comr
Build Solution F7

Rebuild Solution Ctrl +alt+F7
Clean Solution
(%% Build iMX313DSMobility

Rebuild iMX31305Mability
Clean iMX31305Mobility

Advanced Build Commands » Sysgen
Build All Subprojects Clean Sysgen
Rebuild All Subprojects Build and Sysgen

Rebuild and Clean Sysgen

Copy Files to Release Directory Build Current BSP and Subprojects

Make Run-Time Image Rebuild Current BSP and Subprojects

B Open Release Directory in Build Window

Global Build Settings 3
Targeted Build Settings »
Batch Build...

Configuration Manager. ..

Figure 4-3 Incremental BSP Build Libraries
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4.3 Building an XLDR Image

The XLDR is a NAND boot loader that resides in the first 2K bytes of the external NAND device.
The XLDR is the first code to execute on the system when booting directly from external NAND
flash memory.

The NAND flash controller copies the XLDR from the NAND memory to the internal NAND
buffer after reset. After the XLDR is copied, the CPU program counter is set to the base of the
NAND buffer and begins executing the XLDR. The XLDR then loads a secondary boot loader
(such as EBOQT), which provides additional functionality for booting OS images. Once the OS
Image is created, the XLDR image can be generated.

To build an XLDR image NAND for flash, use these steps:

1. Using the Build menu, configure the options as follows:
— Copy Files to Release Directory After Build selected
— Make Run-Time Image After Build unselected

2. Select the Solution Explorer tab of the Platform Builder Solution Explorer window.

3. Expand WINCE600 > PLATFORM > iMX313DS > src > BOOTLOADER.
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4. Right-click on the XLDR folder and select Rebuild.

The XLDR binary image is created in the solution release directory (Figure 4-4).

[; Solution 'imx313dsmobility’ {1 project)
- W@ iMX313DSMobility
=- & C:/WINCESDD
=l £ PLATFORM
¥ (3] ARUBABOARD
: COMMON
DEVICEEMULATOR
- [ H4SAMPLE
. 3 iMX313D5
&~ £ Parameter Files
B 3 src

= (3 BOCTLOADER
B (3] COMMON

----- Subprojects

Sl Solution Explorer ]@ Catalog Items View

& gleso0r
. [~ [gd SBOOT {exduded from build)
XLDR. (exdudec B 'I
COMMON =
Bl (3 DRIVERS | Rebuid
E- (3 AL O Open
(- (3§ MAINSTONEIIL Cpen With...
- [l PRIVATE
= Add *
& CF PUBLIC
..... ﬁ Fawvorites ll'ldl_lle in Build
- [ Parameter Files L
Hl- 3 Freescale LMx31 305: ARmy4r| B Findin Files...
..... SOks (3] Explore

Show in Favorites

Bl Cpen Build Window

Figure 4-4 Building an XLDR Image
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Chapter 5
Downloading the Bootloader

To prepare for downloading the OS images and debugging, you configure and initialize the target
and development workstations.

These procedures include configuring boot mode on the Debug board, and then programming
XLDR and EBOOT.

5.1 Configuring Boot Mode
To configure boot mode, set the switches on the Debug board as described.

NOTE

Switches SW5 through SW10 on the 3-Stack Debug board
are used for Boot mode selection.

The following table shows jumper settings for the NAND Flash boot configuration.

Jumper Setting Configuration
SW6 1
SW5-SW7-SW8-SW9-SW10 0

The following table shows jumper settings for the internal ROM boot configuration.

Jumper Setting Configuration

SW5-SW6-SW7-SW8-SW9-SW10 0

5.2 Programming XLDR and EBOOT Using the ATK Tool

If you receive an i.MX31 3-Stack board without XLDR and EBOOT, you must program them by
using the Advanced Toolkit (ATK). Perform this task after your OS image has been built.

NOTE

Before building XLDR and EBOQT, set the environment
variable IMGNAND =1 in the following location in Platform
Builder:

Project > Properties > Configuration Properties >
Environment
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You may obtain the Advanced ToolKit (ATK) from the i.MX31 BSP package. The ATK
supports KO9F2G08ROA.

Note

If this is your first use of the i.MX31 3-Stack board, we
strongly recommend that you erase the NAND first.

To erase NAND, use these steps:
1. Set the boot mode to internal ROM boot.

2. Power on or reset the device board.

3. Run ADSToolkit.exe (Figure 5-1).

li Administrative Tools

@ Advanced Toolkit ﬁ Uninstall
li Microsoft \NET Framework SDK v2.0 Y B AdvancedToolkit vV1.66

Microsoft Remote Tools Framework 1.00  # -"L FSL_ATK_UserGuide_Std V1.66

@( Set Program Access and Defaults

=t

Programs

Documents M |IFT) Tera Term Pro
Windows CE Updates

Qe

3
—_— 4
[in] Sett .4
= =Hinas Microsaft Visual Studio 2005 ’
@ /_) search y | Windows Embedded CE 5.0 C
%} VMware 3
o Q Help and Support B3 Command Prompt
% =7 Run L‘ﬁ] Cutlook Express
; é Internet Explorer

3 P ovD

-E I Log Off momertum. .. Q ower
£ H Adobe Reader 8
= iOI Shut Down... (=} Windows Media Player

Figure 5-1 Location of Advanced Toolkit Application
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The Advanced ToolKit Configuration screen is displayed (Figure 5-2).

Advanced ToolKit Configuration -0 x|

— Device Setting

@ iMXCPU:  [imaiTo2 7
Device memarny initial

f+ DDR { SDRAM
" Custom Initial File | J

— Host Setting

Communication Channel

% Serial Port: |c0m1 |
™ USB [~ COM-:USE

[~ Bypass the settings

¢Back | Next>

Figure 5-2 ATK Initial Configuration

4. For i.MX CPU, select i.MX31_TO2.
— For Device memory initial, select DDR.
— For Communication Channel of Host Setting, select the appropriate COM
port/USB.

5. Click Next.
6. Click Flash Tool, and then click Go.
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7. Select the options shown in Figure 5-3, and then click Erase to erase the flash.

B Advanced Toolkit (Flash Tool) M=
Operation type Flazh Device
(" Download " Dump [~ Bl Swar [ BET Flash model  [NAND |

" Program (¢ Erazse [ Boundary | Intereave

Operation settings
Address: [0 00000000

Size: 0 10000000

Image
Image File [D'ovwnload/Program input, Dump output)

| Browse. ..

Finizhed!

Flazh eraze successful

Silicon Secunty Tepe [HAB_TYPEL Dewvelopment/Dizable Flash Capacity: 262144 KB

< Cluit E xit Load... Save... Eraze |

Figure 5-3 Erase Flash with ATK
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5.2.1 Program XLDR

To program the XLDR, use these steps:
1. Set the boot mode to internal ROM boot.

2. Power on or reset the device board.

3. Run ADSToolkit.exe. The Advanced ToolKit Configuration screen is displayed
(Figure 5-4).

E Advanced ToolKit Configuration o ]

— Device Setting
@ iMXCPU:  [ima1Toz <]
Device memany initial

{* DDR = SDRAM
™ Custom Initial File | J

—Huost Setting

Communication Channel

{* Seral Port: ICDI"-"I'I vI

i~ USB [~ COM-:USE

[T Bypass the settings

< Back Mesd =

Figure 5-4 Initial Configuration
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Select the following:
— For i.MX CPU, select i.MX31_TO2.

— For Device memory initial, select DDR.

— For Communication Channel of Host Setting, select the appropriate COM

port/USB.
— Bypass the settings can be left blank.

Click Next.
Click Flash Tool, and then click Go.

The Flash Tool screen is displayed.

— For Operation Type, select Program.

— For Flash model, select NAND.

— Configure Address as 0x0.

— For Image File, click Browse to select x1.DR .nbo .
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Click Program, and wait until flashing is successful, as shown in Figure 5-5.

B Advanced Toolkit (Flash Tool)

— Operation type Flazh Device
" Download " Dump [~ Bl Swar  [™ BBT Flash madel [ NAND =l
% Program  ( Eraze | Bounday [ Interleave
Browse... |

— Operation zettings
Address: 0 |UDUUDDUU

Size: 0x | 10000000

— Image
Image File [Dovwnload/Program input, Dump output]

| D4 DR.nbl Browse... |

Finizhed!

Flash program successfull

Silicon Secunty Type [HAB_TYPE] Development/Dizable Flazh Capacity: 282144 KB

< it E uit Load... Save... Program I Stop

Figure 5-5 XLDR Programming
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5.2.2 Program EBOOT

When the ATK finishes programming XLDR.nb0 to the board, program EBOOT.nb0 to the
board.

To program EBOOT, use these steps:

1. Power on or reset the device board.
— For Operation type, select Program and Bl Swap.
— For Flash model, select NAND.
— For Operations settings, set the address as 0x20000.
— For Image File, click Browse to select EBOOT.nb0.

2. Click Program and wait until flashing is successful, as seen in Figure 5-6.

B8 Advanced Toolkit (Flash Tool) Mli=3
Operation type Flazh Device
{* Download £ Dump | Bl Swar [ BBT Flashmodel  [MAND [

(¢ Program © Erase [ Boundany [ Intereave |

Operation zettings
Address: 0= |DDDDDDUU

Size: O« |

Image
Image File [Download/Frograrm input, Dump outpt]

\D:AEBOOT.nbil Browse... |

Finizhed!

Flazh program successfull
Flazh program successfull

Silicon Secunty Type [HAE_TYPE) Development/Dizable Flash Capacity: 262144 KB

< it E xit Load... Save... Frogram |

Figure 5-6 XLDR.nb0 Programming
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3. Set the board for NAND flash boot, using the instructions in Section 5.1, Configuring
Boot Mode.

4. Power on or reset the device board.

5.3

Updating XLDR and EBOOT

You may use either the ATK or Platform Builder to update XLDR and EBOQOT. To do so, repeat
the steps in Section 5.2.1.

54

EBOOT Menu Options

Table 5-1 describes the commands on the EBOOT menu.

Table 5-1 EBOOT Menu Commands

Identifier Item Description
0 IP Address Configures a static IP for the board in order to connect EBOOT with the
Platform Builder. When the DHCP option is enabled this IP address is not
used.
1 Subnet Mask Configures the subnet mask for the board’s static IP address.
2 Boot Delay Configures the time given to execute the Autoboot option of EBOOT.
3 DHCP Enables or Disables the DHCP client of EBOOT. This option allows the board
to obtain a valid IP address from the network DHCP server to connect to
Platform Builder.
4 Reset to factory | Restores the EBOOT default values.
default
configuration
5 Autoboot Configures the boot option for the OS image. The options can be:
e Disabled. At boot will enter the EBOOT menu.
e NK from NOR. EBOOQOT loads the OS image from NOR flash (not used on
3-Stack board)
e NK from NAND. EBOOT loads the OS image from NAND flash OS region.
6 MAC address Configures the MAC address for the board’s external Ethernet controller.
7 Format OS Formats the OS NAND region; erases any existing image in this region.
NAND Region
8 Format all OS Formats NAND flash; erases all NAND regions existing programs, including
NAND Regions EBOOT.
| KITL Interrupt Enables/Disables the KITL interrupt mode instead of the KITL polling mode.
mode
P KITL Passive Enables/Disables KITL passive mode, this option bypasses the KITL
mode connection if it is enabled.
C L2 Cache Enable | Enables/Disables the L2 cache from the ARM processor.
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L2 Cache Mode

Configures the L2 cache mode to be WriteThrough or Write Back.

AHB Clock Configures the AHB clock at 66.5 Mhz or 133 Mhz speed.

Frequency

ARM Clock Configures the ARM core clock at 532 Mhz or 266 Mhz speed.

Frequency

Power Policy Enable/Disable Power Policy. This option should be enabled only if you want
to do a power consumption test.

USB KITL Enable/Disable USB KITL when KITL Passive mode is Disabled

Save Saves the current configuration of EBOOT.

Configuration

Download Image
from Ethernet
Now

Downloads the OS Image or EBOOT image using the Ethernet connection.

Download Image
from USB Now

Downloads the OS Image or EBOOT image using USB RNDIS service.

Launch Existing
Flash Resident
Image Now

Launch the OS image stored in NAND.

5-10
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Chapter 6
Downloading the OS Images

Now that you have added the i.MX31 3-Stack board to your Platform Builder devices, and you
have downloaded the bootloader, you can download the OS image using EBOOT. Make sure that
the 3-Stack board is configured for NAND Flash boot mode, as described in section 5.1.

6.1 Adding the 3-Stack Board to Platform Builder

To add the 3-Stack board to the Platform Builder, use these steps:

1. Connect the 3-Stack board to the network with a standard UTP cable.
2. Connect the 3-Stack board to your host PC using a serial cable.

3. Open a serial console on your host PC with the following settings.
— Baud Rate: 115200
— Data bits: 8
— Parity: none
— Stop bits: 1
— Flow Control: none

6.2 Selecting the i.MX31 PDK Target Device

Use Platform Builder and EBOOT to program the OS kernel image into NAND Flash. When
you have built the OS Image and loaded the XLDR and EBOQOT into the NAND Flash,
change the Boot Settings to NAND Flash Boot, and then use the steps in this section to
program the OS image to the board.

Note

Before building the OS image, ensure that the environment
variable IMGNAND =1 in Platform Builder is set. If not, set
it by selecting Project > Properties > Configuration
Properties > Environment.

4. Ensure that the board is configured to boot from the NAND flash (see Section 5.1,
Configuring Boot Mode).
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5. Power up the 3-Stack board.

The EBOQOT startup sequence should appear in the serial console (Figure 6-1). If the
EBOOT startup sequence is not displayed, program XLDR and EBOQOT using the
procedure in Section 5.2, Programming XLDR and EBOOT Using the ATK Tool.

Microsoft Windows CE Bootloader Common Library Version 1.4 Built Jan 21 2005 17:09:08 =]
Microscft Windows CE Ethernet Bootloader 1.0 for MX31 3DS (Jan 21 2009% 11:36:08)
INFO: Bootloader launched from NAND

INFO: OEMPlatformInit: Imitialized NMAND flash device.

INFO: Loading boot configuration from MAND

PEC debug switch settings: 0Oxl

[KITL will run in PASSIVE mode

mfi = 3, mfn = 12, mfd = 51, pdf = 1

BSP System Configuration:

L2 CACHE ENAELED

MCU PLL = 532000000 H=z

USB PLL = 240000000 H=z

SEER PLL 220147200 H=

ABM CLOCE = 266000000 Hz
IPU CLOCE = 133000000 H=z
AHB CLOCKE = 133000000 H=z
IPG CLOCE = 66500000 H=z
NFC CLOCE = 33250000 H=z

PER CLOCE = 66500000 Hz

SSI1 CLOCE = 1719500 Hz (i
SSI2 CLOCE = 1719900 Hz

FIRI CLOCE = 1875000 Hz

CSI CLOCE = 429573 H=
USB CLOCE = 60000000 H=z
SIM CLOCE = 66500000 H=z

System ready!
Preparing for download...

Press [ENTER] to launch image stored in NAND flash or [SPRACE] to cancel.

Initiating image launch in 3 seconds.

Figure 6-1 EBOOT Startup Sequence

Perform ONE of these steps:

— If you have just erased the NAND and then programmed XLDR/EBOOT, the EBOOT
menu is displayed. Update the MAC Address, and then press X to disable Power
Policy. (Enable the Power Policy only if you want to perform the power consumption
test.)

OR

— Press the spacebar on the host PC to enter the EBOOT menu before the three-second
period ends.
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6. Configure the ETH settings to match your network configuration, for example:

0) IP address: 192.168.0.2
1) Subnet Mask: 255.255.255.0

2) Boot delay: 3 seconds

3) DHCP: Disabled

5) Auto boot: NK from NAND

6) MAC address: EE-04-9F-00-8C-9C
I) KITL interrupt mode: Disable

P) KITL passive mode: Disable
R) USB KITL: Enable

If your networks include a DHCP server, ensure that option 3 DHCP is set to Enabled.

7. In Platform Builder, select Target > Connectivity Options (Figure 6-2).

Sa

om

*

Target Control

Target | Data Tools Window Com

Attach Device

Alt+1

| Connectivity Options...

Debug Message Cptions...

Release Directory Modules, .

Remote Tools

k

|

[

Figure 6-2 Platform Builder Connectivity Options

Freescale Semiconductor i.MX31 PDK 1.5 Windows Embedded CE 6.0 User’s Guide, Rev 1.5

6-3




Device Configuration
Add Device

Delete Device

Semvice Configuration
Kernel Service hap

Core Service Seftings

Service Status

L Target Device Conneckivity Opkions

_ (o x|
Target Device:

IEE Device j
Download:

IEthernet j Settings |
[-]

Tranzport;

IEthernet j Settings |
e

D ebugger:
k.dStub

| Apply I Cloze

Settings |

Help

Figure 6-3 Target Connectivity Options

The Target Connectivity dialog is displayed (Figure 6-3).

8. Select these options:

— For Download and Transport, select Ethernet
— For Debugger, select KdStub

The debugger should be None when the Kernel Debugger is not enabled in Project >
Properties > Configuration Properties > Build Options.

9. Onthe EBOOT menu, press “D” to request the download of the image to the Platform

Builder.
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The download begins, as shown in Figure 6-4.

NOTE

You may need to stop Black ICE software. To do so, in the
Start menu, click Settings > Control Panel >
Administrative Tools > Services. Then right-click on Black
ICE and click Stop.

I) Fitl interrupt mode: Enable -]
P) Eitl passive mode: Enable

C) L2 cache enable: Enable

W) L2 cache mode: WriteThrough

[B) RAHE Clock freg: 133M

In) BBM Clock freq: 532M

) PowerPolicy: Enable

IR} USE EITL: Enable

3) Save configuration

D) Download image from ethernet now

[U) Download image from USE now

IL) Launch existing flash resident image now

[Enter your selection: d

+InitSpecifiedEthDevice

+InitEthTimer

+LANS11xTnit (0xb2000000, 0x00000000, 0xaB8000024, EPIT{0xB80£00cc, OxbEf£954000))
ORLStall 750us (16625Fhz, 0Oxfffe403c, Oxfffe0fTb)

ILANS118: Chip Id 117a Rewvision 0

Inuto Negotiation done

Luto Negotiation done LINK_100MES_FULL

-LAN91CInit (mac = 00:04:9f:00:8c:%9c, re = 1)

INFO: LBNS11lx Ethernet controller initialized.

INFO: MAC address: 0-4-SF-0-8C-5C

—-BELMenu .

INFO: Using device name: "MX3135956"

+EbootSendBootmekndWaitForTftp

Sent BOOTME to 255.235.255.2535

Sent BOOTME to 255.255.255.255

Sent BOOTME to 255.255.255.255 :|

Figure 6-4 EBOOT Request Download Message Screen

10. In the Target Connectivity dialog, in the Download section, click Settings.

The Ethernet Download Settings window is displayed.
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11. When the EBOOT program displays the BOOTME messages, the 3-Stack board device
should be displayed in the Ethernet Download Settings dialog (Figure 6-5). Double-click
the active device, and then click OK.

If the device is not displayed in the Active Devices field, check that the ETH settings are
properly configured and that there are no security software blocking broadcast signals
(such as BlackICE software) on the host PC.

#3 Fthernet Download Settings x|

Target device boot name:

|M>{3135996 |

IP address: 192.168.0.2
Boot loader: 1.0

Active target devices:

misizssos |

TFTP block size in bytes:

I 512 Restore |

Figure 6-5 Ethernet Download Settings
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After selecting a target, the Target Device Connectivity Options screen is displayed with
the i.MX31 device listed under the Download box. The Target Device box should
display CE Device (Figure 6-6).

5 1a rget Device Connectivity Options - | Ellil

Device Configuratian

Add Device Target Device:
Delete Device ICE Devics j
Download:
Service Configuration |Ethem».=:t j Settings |
Kernel Service Map { MX3135996 )
Core Service Settings
Transport:
Service Status IEheme‘t j P |
{ MX3135996 )
Debugger:

| Kdstub | Setiings |

( Mo Prompt On Ermor )

Apply I Closze Help

Figure 6-6 Target Device Connectivity Settings

12. Click Apply, and then click Close.
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6.3 Downloading the OS Kernel Image using EBOOT

If the device is already sending BOOTME signals and the i.MX31 target device is selected
(section 6.2), download the OS kernel image using EBOOT.

1. Click Target > Attach Device (Figure 6-7).
Target | Data Tools Window Con

|%EI Attach Device
a

o
*a

Target Control Alt+1

Connectivity Options...
Debug Message Cptions...

Release Directory Modules, .

Remote Tools 3

Figure 6-7 Attach Device to Download OS Image

The Download Runtime Image to CE Device dialog is displayed, showing the progress of
the download (Figure 6-8).

=100 ]

(7 e i
8 '

Dowrload Completel

E ztimated time left; [16.7 MBE of 16.7 MB copied]
Diownload through: Ethernet
Trarsfer rate: 788 KB /sec

[ Close this dislog box when download completes

Cloze Zamnel

Figure 6-8 Download Complete
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2. Wait until the Platform Builder finishes the OS Image download.
3. At the serial console, press the “Y’ key to begin programming the flash (Figure 6-9).

—LAN91CInit (mac = 00:04:%£:00:8c:%c, re = 1) :J
INFO: LANS11lx Ethernet controller initialized.
INFO: MAC address: 0-4-SF-0-8C-5C
—BELMenu .
INFO: Using device name: "MX313595&"
+EbootSendBootmeAndWaitForTftp
Sent BOOTME to 255.255.255.255
Packet has the following data:
boot .bin [NULL] octet [NULL]
TFTP packet could have 1 name/wvalue pairs
Locked Down Link 1
Src IP 152.168.0.2 Port 03D4 Dest IP 192.168.0.5 Port 042D
Default TFTP block size set to: 512 bytes
There were no options detected in the TFTP
[EthDown: : TFTPD OPEN: :boot.bin
—EbootSendBootmeAndWaitForTftp

BL_IMAGE TYPE BIN

INFO: OEMMultiBINNotify (dwNumRegions = 1, dwRegionStart = 0x57320000).
INFQ: OEMVerifyMemory (C& = 0x9$7320000, PA = O0xB80ZA2000, length = 0x1AC3058)
INFO: Downloading NE NAND image.

TFTF: Desktop losing ACFK, block number = 25703, Ack again

rom offset=0xF1A0000.

ImageStart = 0xS%73A0000, ImageLength = 0x1AC3058, Launchfddr = 0xS7321000

Completed file(s):

[0]: RAddress=0x%7320000 Length=0x1RC3058 Name="" Target=FLASH

ARNING: Flash update requested.
Do you want to continue (y/n)? I hd

Figure 6-9 EBOOT Flash Update
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EBOOT will program the image into flash and display the status using serial debug message

(Figure 6-10).

Locked Down Link 1

Src IP 1%2.168.0.2 Port 03D4 Dest IP 1%2.168.0.5 Port 04253
Default TFTP block size set to: 512 bytes

There were no options detected in the TFTE
EthDown: : TFTED OPEN: :boot.bin

—EbootSendBootmelindWaitForTEtp

EL_IMAGE_TYPE_BIN

INFO: OEMMultiBINNotify (dwNumRegions = 1, dwRegion3tart = 0x57320000) .
INFO: OEMVerifyMemory (CA = 0xS73R0000, PR = O0xBBOR2000, length = 0x1AC3058)
INFO: Downloading NE NAND image.

TFTE: Desktop losing ACE, block number = 25703, Rck again

rom_ offset=0xF1&0000.

ImageStart = 0xST3R0000, ImagelLength = 0x1AC3058, Launchiddr = 0xST3R1000

Completed file(s):

[0]: RAddress=0xS7320000 Length=0x1AC3038 MName="" Target=FLASH

WARNING: Flash update regquested.

Do you want to continue (y/n)?

INFO: Writing NE image to NAND (please wait)...
INFO: Erasing MBND flash blocks [0x5 - 0x1E5].
INFO: Programming NE image from flash cache address OxZ8100000, size = 28061784
INFO: Program is 100% complete.

INFO: Verifying image.

INFO: Read is 100% complete.

INFO: Update of NE completed successfully.
Reboot the device manually...

SpinForever. ..

Figure 6-10 EBOOT Flash Update

4. When the programming is complete, reboot the board.

5. Enter the EBOOT menu. Now the Windows Embedded CE 6.0 system can automatically
boot from NAND Flash. Press L to launch the OS image, or reboot the board to
automatically launch the OS image from NAND.
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6.4

Using UBOOT

To use UBOOQOT, follow these steps:

1.

If you want use the USB KTIL before building the kernel, first remove all USB driver
modules from OSDesignView in Platform Builder.

Open a serial terminal at the host PC.

Connect a serial cable and a USB cable between the board and the PC, and then apply
power to the board.

At the EBOOT menu, change the boot configuration to match the following.
0) IP address: 192.168.0.2

1) Subnet Mask: 255.255.255.0

3) DHCP: Disabled

I) KITL interrupt mode: Disable

P) KITL passive mode: Disable

R) USB KITL: Enable

Configure your host PC network settings to be in the same network as the board.
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6. Press the ‘u’ key to download the image from the USB.

If you are using UBOOT or USB KITL for the first time, you are prompted for
installation options. This installs the RNDIS driver (Figure 6-11).

Found Mew Hardware Wizard

Welcome to the Found New
Hardware Wizard

Thiz wizard helpz you install software faor;

icrogoft Windows CE RMDIS wirtual adapter.

\':1 If your hardware came with an installation CD
i or floppy disk. insert it now.

“Ww'hat do wou want the wizard to do’?

" |nstall the software automatically [Recommended)

% |nstall from a list or specific location [&dvanced)

Click Mest to continue.

¢ Back l et > I Canicel

Figure 6-11 Installing RNDIS Driver on Windows XP

7. Select Install from a list or specific location (Advanced).
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8. Click Next.
You are prompted to select a driver for RNDIS (Figure 6-12).

Found New Hardware Wizard

Please choose your search and installation options.

¥ Search for the best driver in these locations.

|ze the check boxes below to limit or expand the default search, which includes local
paths and removable media. The best driver found will be installed.

[~ Search removable media floppy, CO-ROM... )
¥ Include this location in the search:

|E:\WINCEEDD\F‘UELID.[DMMON\DAK\DHI‘JEHSXj Browse |

™ Dont search. | will choose the driver to install.

Choose this option to select the device driver from a list. Windows does not guarantee that
the driver you choose will be the best match far your hardware.

« Back Mest > Cancel

Figure 6-12 Selecting a Driver for RNDIS

9. Select Include this location in the search and add the following path to the search
location:

<PATH: > \WINCE600\PUBLIC\COMMON\OAK\DRIVERS\ETHDBG\RNDISMINI\HOST\
10. Click Next.
Now the usb8023. inf file will be used to install the RNDIS driver for the board.

11. You are prompted for the usb8023 . sys file to install. This file is usually located at
\WINDOWS\system32\drivers folder for Windows XP.

If you experience installation problems, refer to:
\WINCE600\PUBLIC\COMMON\OAK\DRIVERS\ETHDBG\RNDISMINI\HOST\ howto.txt

12. When the driver is correctly installed, the Microsoft Windows CE RNDIS virtual adapter
from Network Connections will be displayed on the PC.
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6-14

13. Configure this network connection properly. Use a static IP address, and then reboot the
board. Here is an example of the static IP address:

IP address: 192.168.0.4 /Isame subnet, different IP address with board
Subnet mask: 255.255.255.0 //must match the boot configuration on the board

14. Follow the procedure in Section 6.2 to add the device to Platform builder; however, at
Step 10, select “U” (for USB transport) rather than “D” (Ethernet transport).
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Chapter 7
Building and Using the BSP Demo Applications

The BSP supports the following Windows Embedded CE 6.0 applications:

. Camera
° TV-Out
° Rotate

7.1 Camera Application

The camera application demonstrates the capabilities of the camera driver supplied with the BSP.
You can use this application to manipulate the Omnivision OV2640 Camera CMOS sensor, using

the 3-Stack camera driver.

711 Building the Camera Application

To build a Camera application, use these steps:

1. Create an APP folder under the following folder:
\Platform\iMX313DS\Src

2. Create an empty dirs file under the following folder:
\Platform\iMX313DS\Src\App

3. Copy the CAMAPP folder from the \Support\App folder to the
\Platform\iMX313DS\Src\App folder.

4. In the Build menu:
— Copy Files to Release Directory After Build selected
— Make Run-Time Image After Build unselected

5. Select the Solution Explorer tab of the Platform Builder Solution Explorer window.

6. Expand WINCE600 > PLATFORM > iMX313DS > src > App.
7. Right-click on the CAMAPP folder and select Rebuild.

The CAMAPP execution file will be created in the workspace release directory.
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7.1.2

Using the Camera Application

Table 7-1 describes the features and commands for the camera demonstration application.

Table 7-1 Camera Demo Application Features

Feature

Description

Picture Browser

File > Picture browser
View (button at the bottom of the application)

The picture browser is used for viewing a picture.

Picture Zoom

View > Zoom

Ovt2640 sensor does not support zoom.

Change Resolution

View > Resolutions

Can switch output resolution among the following QQVGA, QCIF, QVGA, CIF, and VGA.

Horizontal Flipping

View > Horizontal Flipping

For flipping picture horizontal.

Vertical Flipping

View > Vertical Flipping

For flipping picture vertical.

Options

View > Options

Change Resolution, Zoom, and Rotation in one command.

Capture a still
picture

Capture (button at Capture the bottom of the application) The captured picture is the same
resolution that that you set in View > Resolution.

Save or discard a

1. Press Capture (button at the bottom of the application). The name of the button name

still picture changes to Save or Discard
2. Press Save to save the picture. You may define the saved file name and type (*.jpg
,“.bmp).
3. Press Discard to discard the picture.

Rotation Press Rotate (button at the bottom of the application). The image rotates 90 degrees.

Frame rate display

Displays the current frame rate at the lower right of the application.
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7.2 TV-Out Application

The TV-Out application is \windows\TVOUT . exe. The TV-Out application toggles the
Windows Embedded CE 6.0 desktop between the LCD display and the TV-Out connector.

TV-Out supports PAL and NTSC standards. The default mode for TV-Out is PAL; to change the
mode, call the TV-Out program with a mode parameter.

— tvout.exe 0 sets the TV output format to PAL and sends the Windows Embedded CE
6.0 desktop to the TV-Out connector.

— tvout.exe 1 sets the TV output format to NTSC and sends the Windows Embedded
CE 6.0 desktop to the TV-Out connector.

You can execute tvout.exe in either of two ways:
— Use the Start > Run...window.

— Use the default output format (PAL) by double-clicking on the tvout.exe program.
When the TV is the display screen, double-clicking this file toggles the display to the
LCD.

NOTE
Before running the TV-Out application, close all Windows.

7.3 Rotate Application

The Rotate application is located at \windows\rotate .exe. The Rotate application switches
the display between Portrait and Landscape modes. Landscape Mode has higher performance, but
most settings in Windows Embedded CE 6.0 are designed to use Portrait Mode.

— When the display is in Portrait Mode, double-clicking this file toggles the display to
Landscape Mode.

— When the display is in Landscape Mode, double-clicking this file toggles the display to
Portrait Mode.

NOTE

The Rotate application is designed to configure the Window
settings only in Portrait Mode. Rotate does not support all
applications in both Portrait and Landscape Mode.
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7.4

FM Radio Application

The FM Radio application provides an FM radio station receiver. The Si4702 on the 3-Stack
platform uses the FM radio driver included in the BSP, and sends the sound to the audio output.

7.4.1

Building the FM Radio Application

To build an FM radio application, use these steps:

7-4

Create an APP folder under the following folder:
\Platform\iMX313DS\Src

Create an empty dirs file under the following folder:
\Platform\iMX313DS\Src\App

Copy the FMAPP folder from the \Support\App folder to the \Platform\ iMx313DS\
src\app folder.

In the Build menu:
— Copy Files to Release Directory After Build selected
— Make Run-Time Image After Build unselected

Select the Solution Explorer tab of the Platform Builder Solution Explorer window.
Expand WINCE600 > PLATFORM > iMX313DS > src > App.
Right-click on the FMAPP folder and select Rebuild.

The FMRadioapp . exe file will be created in the workspace release directory.
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7.4.2 Using the FM Radio Application

To use the application, click the FM Radio Application icon. Figure 7-1 illustrates the FM Radio’s

main window. The application window will fit the new client area dimensions after screen
rotation, for example, from Portrait Screen to Landscape Screen. Table 7-2 describes the
controls. Figures 6-2 through 6-5 illustrate the secondary dialogs.

FM Radio Application

104,00

Turnn—p— |I| SetFreq
Turnoff—— | 3 | Savechan

ForvardFreq———— IEI Chanlist

BackwardFreq ‘—E AutoTune

i1

M =] B

Uolume Controls

Figure 7-1 FM Radio Application Main Window

Figure 7-2
Set Frequency Dialog

Save Channel Name

Input Channel Mame:

||:hanneljj

Figure 7-3 Save Channel
Name Dialog

Channel List Dialog
Marmne I Frequency I Lines
Autol 89,00 1
AutoZ 03,10 2
Auto3 104.00 3
< | H

Input Mame  Input Freq
J | Add
| Edit | | Del | | oK |

Figure 7-4 Channel List
Dialog (Portrait Screen)

Channel List Dialog

o | = | T Input Mame

ame requency ines I—
Autol 82,00 1 Tnput Frag
Autoz 93.10 2
Auto3 104.00 3 I

|Edit ” Del |

4 |

Figure 7-5 Channel List Dialog
(Landscape Screen)
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Table 7-2 FM Radio Application Main Window Controls

Control Action
Turn On Plays the displayed frequency.
Turn Off Stops playing the FM radio.
ForwardFreq Increases the frequency in increments of 0.10 MHz.
BackwardFreq Decreases the frequency in increments of 0.10 MHz.
Volume controls Sets the FM radio volume to the specified value. The volume value is shown on the

volume track. Valid settings are 0 (lowest) to 15 (loudest).
e (Click + to increase the volume.
e Click - to decrease the volume

o (Click Mute to silence the radio audio.

SetFreq Displays the Set Frequency dialog. See Figure 6-3. Displays the current frequency. To
change the frequency setting, enter the desired frequency, and then click OK. The input
frequency range is from 87.5 megahertz to 108.00 megahertz.

SaveChan Displays the Save Channel Name dialog. See Figure 6-4. To create a name for the
channel of the selected frequency, enter a channel name, and then click OK. The name
and frequency are saved to a channel list.

ChanlList Displays the saved channel list. See Figure 6-5. You may add, edit or delete a channel.
To play a channel, select the channel and click OK.

AutoTune Performs automatic tuning and saves the scanned channels to a selected channel list.
Click ChanList dialog to check the scanned channels.

7.5 Accelerometer Demo Application

The Accelerometer Demo Application illustrates the automatic rotation of the screen when the
device is rotated. To accomplish the rotation, the application uses the accelerometer driver
included in the BSP, and reads the user-entered X, Y, and Z values.

7.5.1 Building the Accelerometer Demo Application

To build the Accelerometer Demo application, use these steps:

1. Download Windows Mobile 6 Professional and Standard Software Development Kits.

2. Install the SDK.

3. Open Microsoft Visual Studio 2005.

4. Click File > Open > Project/Solution, and select the project at:
SUPPORT\MX31\APPS\ACCAPP

5. Right-click on the test and select Rebuild.

The acctest . exe file will be created in the workspace release directory.
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7.5.2

Using the Accelerometer Demo Application

The following graphic illustrates the main window.

Read
Close |
(carae ]

fuko | w

* Axis

Y Axis

Il

Z Axis

Figure 7-1 Accelerometer Demo
Application Main Window

To use the application, follow these steps:

1.
2.
3.

In the main window, note the X, Y, and Z Axis values.
To calibrate the X and Y Axis values, click Calibrate XY.

To select the X, Y, and Z Axis value update interval, click the down arrow next to Auto,
and select the interval.

To cause the screen to rotate automatically when the device is rotated, click the down
arrow next to Auto, and select Auto Rotate.

Freescale Semiconductor i.MX31 PDK 1.5 Windows Embedded CE 6.0 User’s Guide, Rev 1.5 7-7




7.6 Wi-Fi Connection

This BSP includes Wireless LAN connectivity support through the CSR APM6628 chip included
in the i.MX31 PDK.

To initialize the Wi-Fi connection, use these steps:

1. Go to the \windows folder and double-click the LoadDriveriMX31.exe icon (Figure
7-3).

File Edit View Go (7] [x]

Ile]*] =] <] =

— -

v O g T v e

Diesktop Favarites Fonts Help Programs Fecent
—— L [ M —r
A 2 A -

£ | (F__

Startlp acctest ceconfig ETCHA

& = iy

% =

gpsconfig GpsctSer.., loader

T I # -

LtoManager LtoManag... rotate

sta tral Lfsdio

cetlkitl cetlstub

%..:::Eii.;}Winduw: H__'_j 12:58 PM !@ :%

Figure 7-3 Wi-Fi Configuration Application

NOTE

The LoadDriverimx31 application should be executed only
once. Additional attempts may cause WLAN driver instability.

7-8 i.MX31 PDK 1.5 Windows Embedded CE 6.0 User’s Guide, Rev 1.5 Freescale Semiconductor




The UFMPI dialog is displayed (Figure 7-4). This built-in application is included in the
Windows Embedded CE 6.0 image by default.

-
E

My Device

IP Information wWireless Information

Select a network and press connect or rigﬁf-l:lil:k far mare
options, To add a nesw network, double-click ‘Add Mew:',

Y add Mew... o
& AguaBie

@ MADTest (preferred)
& TPO-GLESTWL-54 E

FOTOUT WAM Nkl A

Status: Connected to MADTest

r"'1E|ji-E| F'lEI 0

Signal Strength:  Excellent
Motify me when new wireless networks are available

Connect Advanced... | | View Log...

.."fj'HUFMN ||g§'._._fLr 1:03 PM |@|%

Figure 7-2 UFMPI Dialog
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2. On the Wireless Information tab, select the Wireless Network that you want to connect to,
and then click Connect.

The Wireless Network Properties dialog is displayed for configuring the wireless
connection settings (Figure 7-4).

[ This is a computer-to-computer {ad hoc) network:
wireless access points are not Lsed

-Wireless network key (WEP)

This network reguires a key for:
Encryption: |Di5abled

E3
Authentication: |Dpen [~]

Metwork key: |

Key inde: |1

The keyis provided autornatically

Me IjiEI F'lEI 0

-IEEE 802.1X Authentication
|:| Enable 802, 1% authentication on this netwark
E&P i:ype: TLS EI

Properties

Cancel

.....

.......

||g=l_l,_,r 12:n4pm|@|%

Figure 7-3 Wireless Network Properties

3. Select the needed settings, and then click OK.

i.MX31 PDK 1.5 Windows Embedded CE 6.0 User’s Guide, Rev 1.5 Freescale Semiconductor




	Chapter 1 Introduction
	1.1 System-on-Chip Support Package (SoC) 
	1.2 Production Quality OAL (PQOAL)
	1.3 i.MX31 3-Stack Platform Files
	1.4 Sample Workspace
	1.5 Support Files

	Chapter 2 Installation
	2.1 Installing the Development Tools and BSP
	2.2 Removing i.MX31 PDK BSP
	2.3 Load Sample OS Design Solution

	Chapter 3 Configuring OS Images
	3.1 Selecting the Image Build Type
	3.2 Configuring the BSP Environment Variables
	3.3 Configuration Properties Environment Variables

	Chapter 4 Building OS Images and Bootloader
	4.1 Building SoC Libraries
	4.2 Building Run-Time Images
	4.2.1 Building the BSP for the First Time
	4.2.2 Obtaining a Clean Build for the BSP
	4.2.3 Performing an Incremental BSP Build

	4.3 Building an XLDR Image

	Chapter 5 Downloading the Bootloader
	5.1 Configuring Boot Mode
	5.2 Programming XLDR and EBOOT Using the ATK Tool
	5.2.1 Program XLDR
	5.2.2 Program EBOOT

	5.3 Updating XLDR and EBOOT
	5.4 EBOOT Menu Options

	Chapter 6 Downloading the OS Images
	6.1 Adding the 3-Stack Board to Platform Builder
	6.2 Selecting the i.MX31 PDK Target Device
	6.3 Downloading the OS Kernel Image using EBOOT
	6.4 Using UBOOT

	Chapter 7 Building and Using the BSP Demo Applications 
	7.1 Camera Application
	7.1.1 Building the Camera Application
	7.1.2 Using the Camera Application

	7.2 TV-Out Application
	7.3 Rotate Application
	7.4 FM Radio Application
	7.4.1 Building the FM Radio Application
	7.4.2 Using the FM Radio Application 

	7.5 Accelerometer Demo Application
	7.5.1 Building the Accelerometer Demo Application
	7.5.2 Using the Accelerometer Demo Application

	7.6 Wi-Fi Connection

	Word Bookmarks
	OLE_LINK3




