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1 Overview 

The Kinetis Design Studio IDE is a 

complimentary integrated development 

environment for Kinetis MCUs that enables 

robust editing, compiling and debugging of your 

designs. Based on free, open-source software 

including Eclipse, GNU Compiler Collection 

(GCC), GNU Debugger (GDB), and others, the 

Kinetis Design Studio IDE offers designers a 

simple development tool with no code-size 

limitations. Furthermore, Processor Expert 

software enables your design with its knowledge 

base and helps create powerful applications with 

a few mouse clicks. 
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2 Release Contents 

- Eclipse Luna 4.4 Framework 

- Host operating systems: 

- Windows® 7/8 (32-bit binaries running on 32 and 64-bit OS) 

- Linux® (Ubuntu 14.04 (deb), RedHat/Centos 7 (rpm)) (64 bit binaries), requires 32-bit 

libraries for GNU ARM Embedded (launchpad) tools 

- Mac OS X 10.10 ("Yosemite") with Segger support 

- GDB debugger with support for the following debug interface hardware: 

- SEGGER J-Link (w/SEGGER GDB Server) 

- P&E Multilink (w/P&E GDB Server) 

- CMSIS-DAP (w/OpenOCD GDB and OpenSDA embedded circuit) for selected 

boards/devices 

- Command Line (CL) debugging with GDB and OpenOCD TCL 

- Additional device support is added through Kinetis SDK Eclipse updates.  

- Support for additional downloadable Eclipse plug-ins including RTOS-awareness (including 

MQX™ and FreeRTOS) 

- Project wizard to create bare metal, Kinetis SDK and Processor Expert software projects 

- Processor Expert software with support for Kinetis SDK 

- Languages supported: Assembly, C and C++ (all with no code size restrictions) 

- GNU tools for ARM® Embedded Processors (launchpad) 4.8 tool chain and libraries (Q3_2014 

release) 

- Conversion assistant to convert pre-V3.0.0 KDS projects to GNU ARM Embedded projects 

- Industry standard Eclipse Framework with CDT for C/C++ 

- Kinetis SDK peripheral drivers and CMSIS compliant startup code 

- GNU ARM® Eclipse plugins for managed make projects and make-file projects 

- Support for MQX project creation and MQX kernel awareness (available as MQX download) 

- Compatible with Eclipse plugins either from the Eclipse ecosystem or from partners 

 

Important: because the GNU ARM Embedded (launchpad) tool chain for Linux is 32-bit only, it 

requires the necessary 32-bit libraries installed. See section 4 of this document. Follow carefully the 

installation instructions in the User's Guide, both for Mac OS X and Linux. 

3 What's New in this Release 

The V3.0.0 release comes with the following major changes: 

- Mac OS X Support: This is the first release with support for Mac OS X "Yosemite" which 
includes run control/debug support with Segger J-Link. P&E Multilink and OpenOCD support 
might be added at a later date. 

- The Eclipse IDE and framework has been moved to Luna (4.4). 
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- Launchpad GNU ARM Embedded Toolchain: instead of a custom toolchain, this release 
includes the GNU ARM toolchain and libraries as released by ARM (4_8-2014q3-20140805 
release) with GNU libraries for devices with less than 1 KByte of RAM. The Project menu 
contains a KDS Upgrade Assistant menu item. 

- EmbSysReg Register Detail Viewer: A register view to inspect Cortex core and peripheral 
registers is included in the product. 

- Processor Expert V3.0.0: This release comes with an updated Processor Expert RT7 release. This 
release includes support for component repositories and supports the V1.0.0, V1.1.0 and V1.2.0 of 
the Kinetis SDK. Adding new drivers to an SDK project will automatically add the necessary 
include folders to the project. The Processor Expert components for the SDK are part of the SDK 
and need to be installed from the SDK installation folder, see next section. 

- New Project Wizard: The wizard offers a choice of compilers at the end of the dialogs to choose 
from GNU (default), IAR and Keil compiler. IAR and Keil projects cannot be used directly with 
KDS, but with IAR and Keil tool chains (separate from KDS). The wizard offers a better way to 
select the Kinetis SDK to be used in the project: a drop-box, environment variable or an absolute 
path. 

- Updated GNU ARM Eclipse (http://gnuarmeclipse.livius.net/) plugins with many bug fixes, 
improvements and support for switching tool chains. The IDE does not change the PATH to the 
GNU toolchain any more, instead it uses the project, workspace or global path to the GNU ARM 
toolchain to make it easy to use different toolchains. 

- Updated SEGGER and P&E debug plugins to the latest and greatest versions. The wizard creates 
launch configurations for all the supported debug connections automatically and with the device 
name set. 

- New Welcome View which points to Kinetis Design Studio and Kinetis SDK web sites. 

- The installer creates a shortcut in the program group under windows according to the Microsoft 
guidelines. 

- Updated and extended KDS porting guide and KDS User guide documentation. 

- Bug Fixes: This release contains numerous bug fixes, enhancements and performance. A detailed 
list of Processor Expert fixes can be found after installation in the 
<installation_path>\eclipse\ProcessorExpert folder. 

4 Migrating to GNU ARM Embedded (Launchpad) Tools 

This release uses the GNU ARM Embedded (launchpad) toolchain. To use existing KDS v2.0.0 projects with KDS 
V3.0.0 requires a small modification in the linker settings. Additional details are documented in the Freescale 

Kinetis Design Studio community: https://community.freescale.com/docs/DOC-103698. 

To migrate an existing 'legacy' project to a 'launchpad' project, usually only the linker settings need to be 

changed. To do this, go into the project properties, and check the 'Other linker flags' settings of the Linker. 

The table below shows the difference between the two: 

Legacy 'Other linker flags' Launchpad 'Other linker flags' 

<none> -specs=nosys.specs 

https://community.freescale.com/docs/DOC-103698
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Legacy 'Other linker flags' Launchpad 'Other linker flags' 

-nanolibc -specs=nano.specs -specs=nosys.specs 

 

To assist migration of existing (pre-V3.0.0) projects, the Project menu includes a KDS Upgrade Assistant: 

Known Issues: 

1) The converter does not distinguish between Executable projects and Static Library projects. In the latter 
case the options for converting Newlib-nano and adding semihosting should be suppressed. 

2) When selecting options to add _exit() implementation and semihosting=rdimon on projects from 

KSDK_1.1.0rc3\demos\hello_world\kds a Cross ARM C Linker errors reports "multiple definition of 
_isatty. It is necessary to remove the user definition of _isatty. 

3) If you get a linker error about _lseed() (or _sbrk(), _kill(), etc) undefined, then probably 
semihosting support has been specified in the conversion assistant.   
One solution is to add -specs=rdimon.specs to the linker options. This will provide semihosting to 
the application. 

The other option is to add  -specs=nosys.specs linker option. This will provide 'do-nothing' options 
to the library, and no text will be printed if your application is using printf() or other ways of printing. 

GNU ARM Embedded (launchpad) on Linux 

Because the GNU ARM Embedded tools are 32-bit only for Linux, on Ubuntu 14.04 64-bit (and others) you may 
see error messages suggesting that arm-none-eabi-gcc could not be found. The tools do exist, however the system 

doesn't know how to run them. This is because the 32-bit compatibility packages need to be installed: See 
http://gnuarmeclipse.livius.net/blog/toolchain-install for details and suggested solution. 

5 Using Kinetis Design Studio with the Kinetis SDK 

Before using Kinetis Design Studio with the Kinetis SDK, the KSDK Eclipse Update must be installed. Unless this 
update is installed, Eclipse cannot generate Kinetis SDK-compatible projects. 

To install the necessary files: 

http://gnuarmeclipse.livius.net/blog/toolchain-install
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1. Have the Kinetis SDK installed (e.g. in C:\Freescale\KSDK_1.2.0) 

2. In Kinetis Design Studio, use the menu Help > Install New Software 

3. Press the Add button 

4. In the 'Add Repository' dialog, use the 'Archive' button to browse for the .zip file inside 

tools\eclipse_update folder of the SDK  

5. Press OK 

6. Select all packages (screenshot shown for Kinetis SDK V1.2.0): 

 

7. Press 'Next >' to complete the installation. 

8. A restart of Eclipse is needed at the end of the installation. 

6 Kinetis Design Studio Updates 

NOTE: Before running the Eclipse updater, make sure that you have the needed privileges (read/write permissions) 

for your Eclipse installation folder. 

After the release of the product, additional updates can be installed through the Kinetis Design Studio Update Site 

(http://freescale.com/lgfiles/updates/Eclipse/KDS): 

1. In Kinetis Design Studio, use the menu Help > Install New Software. 

2. Select the Freescale KDS Update Site (http://freescale.com/lgfiles/updates/Eclipse/KDS) into the "Work 

with" field- 

3. Choose and install the updates. 

To update the P&E debugging support, use the following Eclipse Update site: 

http://www.pemicro.com/eclipse/updates 

To update the SEGGER debugging support, download the latest SEGGER software from 

http://www.segger.com/jlink-software.html and install it. It will detect the installation folder of KDS and updates 

the drivers. 

To update the GNU ARM Eclipse (http://gnuarmeclipse.livius.net/) build tools, use the following Eclipse Update 

site: 

http://gnuarmeclipse.sourceforge.net/updates 

7 OpenOCD 

KDS comes with OpenOCD (http://openocd.sourceforge.net/) with OpenSDA (http://www.freescale.com/opensda) 

debugging support. The following boards are supported with OpenOCD and CMSIS-DAP/mbed firmware on the 
board: 

http://freescale.com/lgfiles/updates/Eclipse/KDS
http://www.pemicro.com/eclipse/updates
http://www.segger.com/jlink-software.html
http://gnuarmeclipse.livius.net/
http://gnuarmeclipse.sourceforge.net/updates
http://openocd.sourceforge.net/
http://www.freescale.com/opensda
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 FRDM-KL02Z,  FRDM-KL05Z 

 FRDM-KL25Z, FRDM-KL26Z, FRDM-KL46Z 

 FRDM-K22F, FRDM-K64F 

 TWR-K24F120M 

All other boards not listed are considered as not supported (e.g. the FRDM-K20 is NOT supported with OpenOCD). 

 

Installation of OpenOCD on Linux 

A udev rules file is used when installing Kinetis Design Studio on Linux host. You might need to run the rules files 
after installation in order to set the correct permissions, otherwise OpenOCD will not be able to connect to the 
board. The udev rules file is located in: 

 <installationPath>/openocd/openocd.udev 
To run the rules file: 

1. Locate the udev rules file and copy it into the configuration directory (for example under /etc/udev/rules.d/) 

2. Rename the udev rules file to 99-openocd.rules (for example) 

3. Optionally the permissions allocated by the rules file can be adjusted. By default this requires users to be in 
the plugdev group. 

4. Run the command udevadm control --reload-rules to instruct udev to reload its rules 

8 Register Detail Viewer 

The EmbSys Register Detail viewer is included with the product. To open the view the first time , use the menu 
Window > Show Views > Other > Debug to open the viewer. 

 

Use the 'wrench' icon to select the chip/device: 

http://mcuoneclipse.com/2014/05/29/how-to-add-register-details-view-in-eclipse/
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Select SVD(CMSIS) for the Architecture with Freescale for the vendor and the matching device/chip: 

 

 

 

 

 

Double click on a register to read/modify the values: 

 

 

 

 

 

 

 

 

The values in green color are read from the device and can be modified. 

9 Devices Supported 

Kinetis Design Studio supports a broad range of Freescale Kinetis devices, and more can be added with the Eclipse 

updater mechanism and serviced packs. 

The following devices are supported with the Kinetis SDK (requires Kinetis SDK installed and Kinetis SDK Eclipse 

Update Files installed in KDS). 

Devices/Boards listed in the New Project Wizard (File > New Kinetis Project) (screenshot shows boards listed after 

adding Kinetis SDK v1.2): 

 

Devices supported (note that additional device support and board support gets installed with the Kinetis SDK 

Eclipse tool updates, e.g MKL03Z32xxx4, MKL33Z64xxx4, MKL43Z256xxx4, MKM34Z256xxx7, 

MKV46F256xxx15): 
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10 Known Issues and Workarounds 

For the latest information, training material and Frequently Asked Questions, visit the Kinetis Design Studio 
Community at https://community.freescale.com/community/kinetis-design-studio. 

Note: Check the Freescale downloads from the web (http://www.freescale.com/kds) and the updates (menu Help > 
Install New Software using the KDS update site (http://freescale.com/lgfiles/updates/Eclipse/KDS). 

- Windows Command Line Limit, KDS-178: Under Windows there is a command line length limitation of 
8192 characters. If the command line length to the compiler or linker exceed that limit, the command line 
gets truncated and the build will fail. 
Workaround: Shorten the path to files and folders as much as possible. Instead of absolute paths, use project 
relative paths or use the Windows 'subst' drive letters to create shorter paths to the sources. Alternatively, 
build libraries and link large projects with libraries instead of individual object files. Another solution is to 

use the GNU ARM Eclipse Build Tools from 
https://sourceforge.net/projects/gnuarmeclipse/files/Build%20Tools/, see this article: 
http://mcuoneclipse.com/2015/03/29/solving-the-8192-character-command-line-limit-on-windows/. 

- Administrative rights to Eclipse installation folder for updates: Users must have write access to the 
KDS installation directory to install new Eclipse plugins. This means that on Linux users need to launch 
KDS with root privileges when installing new plugins. 

- Conditional watchpoints and breakpoints: Conditional breakpoints and watchpoints, including those 
using ignore counts, do not work always. 
Workaround: do not use conditions for breakpoints and watchpoints, instead check for condition in the code 
and set a normal breakpoint. 

- Symbolic Link to libudev for Linux: Like many other Linux packages, users of Ubuntu 14.04 must create 
a symbolic link to libudev. 

Workaround: 
ln -s /lib/x86_64-linux-gnu/libudev.so.1.3.5 /usr/lib/libudev.so.0 

- Installation time on Ubuntu: Users attempting to install KDS using the Ubuntu Software Center may   
find that the Software Center claims to be installing for a long period of time, then returns to the start screen 
without emitting an error or installing the product. This is because the Software Center runs a quality 
checking tool, lintian, on the package before installing it. This tool is not implemented in a scalable manner, 

and doesn't handle the large KDS packages well. Users of high-end machines may find they are able to 
install successfully. 
Workdaround: install using the command-line tool: dpkg 

- Build binary not found: Occasionally after a successful build Eclipse does not find the built binary. This 
can manifest in a number of ways: The project does not show the Binaries meta-folder in the Project 
Explorer view, when the debug button on the debug toolbar is pressed the Debug configuration fails to 

launch a debug session because it reports binary file not found. 
Workaround: refresh the project folder (F5 under Windows). 

- PEXMCU-531: Compiler error if using the TSS Processor Expert component. The compiler is because 
the component sources are using asm() instead of __asm(). Workaround described in 
https://community.freescale.com/message/435546#435546 

- KDS-223: Doing a reset command on the FRDM-K22F and OpenOCD debug connection gets stuck in 

the watchdog reset handler. Workaround is to use an alternative debug connection (P&E Multilink or 
SEGGER J-Link). 

- KDS-190: Stepping over an endless loop (branch instruction pointing to itself) might fail with OpenOCD. 
Workaround: set a breakpoint on the loop statement. 

https://community.freescale.com/community/kinetis-design-studio
http://www.freescale.com/kds
https://sourceforge.net/projects/gnuarmeclipse/files/Build%20Tools/
http://mcuoneclipse.com/2015/03/29/solving-the-8192-character-command-line-limit-on-windows/
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- KDS-189: Debugging, downloading and stepping with OpenOCD is slow compared to other debug 
solutions. Workaround is to use alternative debug connections like P&E Multilink or SEGGER J-Link. 

- KDS-240: The OpenOCD in KDS v3.0.0 is the same as in KDS v2.0.0, therefore any newer Kinetis 
devices are not supported with OpenOCD. Workaround is to use an alternative debug connection (P&E 

Multilink or SEGGER J-Link). 

- Using TSS component: adding the TSS component for non-Kinetis SDK Processor Expert project will 
cause a compilation error. Workaround is documented here: 
https://community.freescale.com/thread/330174 

- Mac OS X and Eclox: The installation of the Doxygen Eclox Eclipse plugin (http://home.gna.org/eclox/) 
fails under Mac OX with an error message. That plugin is not maintained anymore and a fix is not likely. 

- Moving/using projects between different host operating systems: If using a project created/used on a 
different operating system (e.g. migrating a project from Windows to Linux), it is recommended to delete 
the output (usually named 'Debug') folder of the project to enforce proper regeneration of the make files, as 
a 'clean' operation alone might not be enough. 

- The GNU ARM Eclipse plugins have now a linker panel check box to specify the --specs=nano.specs. 
Checking that box and in addition to have this option present in the 'Other linker flags' will cause the link 

phase to fail. The solution is to specify the option only once. 

- KDS-277: Creating a new project with the wizard, for some devices (KW01Z128, KV32, K70, K60, K53, 
K51, K50, K30, K20, K10) it is possible that the debug configuration settings for P&E have not the device 
name populated, and debugging will fail. Workaround: In the debug/launch configuration for P&E, select 
the matching device. 

- KDS300KI004: Creating a new Processor Expert Board (MRB-KW019032E, FRDM-KL25Z, 

FRDM-KL26Z and TWR-KW24D512) project without Kinetis SDK enabled result in build errors because 
of Target Processor not selected. Workaround: Create the project not for the board, but use the 
microcontroller of the board during project creation instead. 

11 Revision history 

Table 12. summarizes revisions to this document. 

Table 12. Revision History 

Revision Change description 

Rev. 0 Initial Version 

Rev. 1 Added items after formal release. 
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