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Component Development Environment
Installation Guide

1.Introduction

The Component Development Environment (CDE) is ~ Contents
available as an update package (plug-in) for the Eclipse
IDE for C and C++ developers 3.6.1 (or higher). This 1. Introduction ..........ccccccocoviiinicinininiccies 1

document describes the installation procedure. Prerequisites ..................................................... 1
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2. Prerequisites

The CDE is a plug-in to the Eclipse IDE for C and C++
developers 3.6.1 (or higher). It also requires the
presence of the Processor Expert Component Library.

If you are using an existing Eclipse environment, make
sure that you have installed the supported version of
Eclipse. If you have not installed Eclipse yet,
download the supported version from:
http://www.freescale.com/processorexpert.

You can link to the Processor Expert Component Library from one of two sources:
e A CodeWarrior tools installation (which includes Processor Expert software by default)

* Processor Expert Microcontroller Driver Suite version 5.3 or later

If you are planning to use the Microcontroller Driver Suite, make sure the Microcontroller Driver Suite
version 5.3 is installed within Eclipse first. You can obtain this product and installation details from:
http://www.freescale.com/processorexpert.

R
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2.1. Windows

To install the product on the Windows host system, following are the prerequisites:

e Ifthe Eclipse IDE is installed in the Program Files folder, you need administrator rights to install
CDE.

¢ [f you have a non-administrative user account, install Eclipse IDE and CDE in another folder. For
example, C:\CDE.

¢ Eclipse stores your projects in a workspace folder that you can name as you wish. However, this
folder must be placed in a location where you have full access. For example,
C:\Profiles\<username>\workspace.

The product has been tested on:
¢ Windows Vista Home Premium (32-bit)
e  Windows 7 Home Premium (32-bit)
¢  Windows XP Professional (32-bit)
e  Windows 7 Professional (32-bit)

2.2. Linux

Eclipse stores your projects in a workspace folder that you can name as you wish. However, this folder
must be placed in a location where you have full access. Make sure your workspace has read/write
permissions set to be accessible by Eclipse.

The product has been tested on Linux Ubuntu 8.10 (32-bit).

3.Installing CDE

Table 1 lists the contents of the CDE installation package.
Table 1. Component Development Environment Installer Contents

File Description

com.freescale.eclipse.3.6.updater.custom.updatesite.zip FSL Eclipse Updater

com.freescale.eclipse3.6.ComponentDev1.0.1ForDriverSuite. | Component Development Environment for MCU
updatesite.zip Driver Suite 5.3

com.freescale.eclipse3.6.ComponentDev1.0.1.updatesite.zip Component Development Environment

Standalone
CDEUG.pdf User Guide
CDEINSTALLUG.pdf Product Installation Guide
README.txt Last minute release information (text format)

Overview of the CDE installation process:
1. Use the Eclipse IDE’s Add New Software mechanism to install the Freescale Eclipse Updater.
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2. Use the Eclipse IDE’s Add New Software mechanism to connect to an “update site” that is part
of this package. This contains the actual CDE. There are two update sites in this package. One
contains a version of CDE that works alone. The other contains a version of CDE that works with
the Microcontroller Driver Suite version 5.3. Pick the one that works for your setup.

3. If you are installing the CDE to work with the Microcontroller Driver Suite, that must be
installed first. For more information, refer to the Prerequisites topic.

3.1. Installing FSL Eclipse Updater
To install the CDE, you first need to install the FSL Eclipse Updater (included in this product).

NOTE If you have already installed FSL Eclipse Updater in this Eclipse IDE, you can
skip to the next section. While it is necessary to install FSL Eclipse Updater
first, you only need to install it once. Once installed, it is not required to install it
again in subsequent updates.

1. Launch the Eclipse environment.
2. Select Help > Install New Software from the main menu bar. The Available Software window
appears (Figure 1).

Figure 1. Available Software Window
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3. Click Add to create a new update site. The Add Repository dialog box appears.
4. Type a name for the update site in the Name text box, for example, Updater (Figure 2).
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5. Click Archive and find the updater installation package (Figure 2).

Figure 2. Add Repository Dialog Box
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6. Click OK. The FSL Eclipse Updater appears in the Available Software window (Figure 3).

Figure 3. FSL Updater in Available Software Window
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7. Select FSL Eclipse Updater Custom Actions and click Next. The Install Details screen
appears (Figure 4).
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Figure 4. Install Details Screen
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8. Click Finish

9. Click OK. You will see another screen about trusting the Freescale certificate. You must actively
select the certificate before continuing; it is off by default (as it should be). Click OK. Once
accepted, restart Eclipse (Figure 5).

Figure 5. Software Updates Dialog Box
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When the installation of the updater is complete, you can move on to install the CDE.

3.2. Installing CDE

If you intend to use the CDE in conjunction with the Microcontroller Driver Suite version 5.3, that
product must be installed first. For more information, refer to the Prerequisites topic, and ensure that you
install it first.

1. Launch the Eclipse environment.
2. Go to Help > Install New Software.
3. Click Add to create a new update site. The Add Repository dialog box appears.
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4. Type a name for the update site in the Name text box, for example, CDE (Figure 6).

5. Click Archive and specify the product installation package, in the Location text box. Pick the
update site you wish: either the standalone or the version for use with the Microcontroller Driver
Suite. Table 1 lists all the files.

Figure 6. Specify Product Installation Package Details
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6. Click OK. The CDE package appears in the Available Software window (Figure 7).

Figure 7. Component Development Environment Package
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7. Select Component Development Environment in the Name column, and click Next. The
Install Details screen appears (Figure 8).
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Figure 8. Install Details Screen — Component Development Environment
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8. Click Next. The Review Licenses screen appears (Figure 9).

Figure 9. Review Licenses Screen
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9. Accept the license agreement and click Finish.

10. Select Freescale certificate and click OK (Figure 10).
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Figure 10. Certificate Selection
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11. Click Restart Now in the Software Updates dialog box to restart Eclipse (Figure 11).

Figure 11. Certificate Selection
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3.3. Connecting to the Component Library

The CDE points to the Processor Expert Component Library. When you first launch the CDE, you may
see a dialog box stating that it cannot find the Processor Expert folder.

If this happens, click the button in the dialog to open the Preferences panel (Figure 12). Use the Browse
button to locate the Processor Expert folder.
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Figure 12. Preferences Panel
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For example, in a default installation of the CodeWarrior 10.2 tools, the path is as noted in Figure 12.
Once you make the change, the tool restarts. This completes the installation of the CDE.

After successful installation, the CDE enables a new perspective in the Eclipse environment (Figure 13).
Select Windows > Open Perspective > other ... then click the CDE to display the perspective.

Figure 13. Processor Expert Perspective
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If the wizard icon W is green, a valid license was found. If not, then place the I icense.dat file in
the Processor Expert directory. The directory location varies depending on the host environment in
which the CDE is installed. It can work with Eclipse IDE associated with a variety of tools such as the
CodeWarrior tools. However, you should have no trouble finding it. It begins with the installed location
of the host environment. Here are some examples.

<Eclipse_with_Driver_Suite5.3_Installation_Path>\eclipse\
ProcessorExpert>
<CW10.2_lInstallationPath\MCU\ProcessorExpert>

To obtain a license, download a free version of the tools or purchase a commercial version. You can
learn about the CDE at: http://www.freescale.com/processorexpert.

If you have license problems, contact Freescale support at: http://www.freescale.com/support.
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You can start using the CDE by clicking the Wizard Icon or selecting File > New> Embedded
Component to create a new Processor Expert Component. For more information, refer to the User
Guide or Quick Start Guide.
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How to Reach Us:

Home Page:
www.freescale.com

E-mail:
support@freescale.com

USA/Europe or Locations Not Listed:
Freescale Semiconductor

Technical Information Center, CH370
1300 N. Alma School Road

Chandler, Arizona 85224
+1-800-521-6274 or +1-480-768-2130
support@freescale.com

Europe, Middle East, and Africa:
Freescale Halbleiter Deutschland GmbH
Technical Information Center
Schatzbogen 7

81829 Muenchen, German

+44 1296 380 456 (English

+46 8 52200080 (English)

+49 89 92103 559 (German)

+33 1 69 35 48 48 (French)
support@freescale.com

Japan:

Freescale Semiconductor Japan Ltd.
Headquarters

ARCO Tower 15F

1-8-1, Shimo-Meguro, Meguro-ku,
Tokyo 153-0064, Japan

0120 191014 or +81 3 5437 9125
support.japan@freescale.com

Asia/Pacific:

Freescale Semiconductor Hong Kong Ltd.
Technical Information Center

2 Dai King Street

Tai Po Industrial Estate

Tai Po, N.T., Hong Kong

+800 2666 8080
support.asia@freescale.com
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Information in this document is provided solely to enable system and software implementers to use
Freescale Semiconductor products. There are no express or implied copyright licenses granted
hereunder to design or fabricate any integrated circuits or integrated circuits based on the information in
this document.

Freescale Semiconductor reserves the right to make changes without further notice to any products
herein. Freescale Semiconductor makes no warranty, representation or guarantee regarding the
suitability of its products for any particular purpose, nor does Freescale Semiconductor assume any
liability arising out of the application or use of any product or circuit, and specifically disclaims any and
all liability, including without limitation consequential or incidental damages. “Typical” parameters that
may be provided in Freescale Semiconductor data sheets and/or specifications can and do vary in
different applications and actual performance may vary over time. All operating parameters, including
“Typicals”, must be validated for each customer application by customer’s technical experts. Freescale
Semiconductor does not convey any license under its patent rights nor the rights of others. Freescale
Semiconductor products are not designed, intended, or authorized for use as components in systems
intended for surgical implant into the body, or other applications intended to support or sustain life, or for
any other application in which the failure of the Freescale Semiconductor product could create a
situation where personal injury or death may occur. Should Buyer purchase or use Freescale
Semiconductor products for any such unintended or unauthorized application, Buyer shall indemnify and
hold Freescale Semiconductor and its officers, employees, subsidiaries, affiliates, and distributors
harmless against all claims, costs, damages, and expenses, and reasonable attorney fees arising out of,
directly or indirectly, any claim of personal injury or death associated with such unintended or
unauthorized use, even if such claim alleges that Freescale Semiconductor was negligent regarding the
design or manufacture of the part.

Freescale, the Freescale logo, CodeWarrior and ColdFire are trademarks of Freescale Semiconductor,
Inc., Reg. U.S. Pat. & Tm. Off. Flexis and Processor Expert are trademarks of Freescale
Semiconductor, Inc. All other product or service names are the property of their respective owners
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